lucasnap's picture

_Inodelookup invalid inode [0x0]


We've just upgraded our Xsan volumes from 10.6.8 Xsan 2.2.2 to 10.8.5.
This went well, apart for one issue.

I needed to reset all the permissions (we went from OD to AD) and while propagating the permissions (and touching all the files) I get about 500 of these errors:

fsm[3962]: Xsan FSS 'XsanVolume[0]': _Inodelookup invalid inode [0x0]
fsm[3962]: Xsan FSS 'XsanVolume[0]': _Inodelookup invalid inode [0x0]
fsm[3962]: Xsan FSS 'XsanVolume[0]': _Inodelookup invalid inode [0x0]

Always the address 0x0.

I've run cvfsck -jv and cvfsck -nv but the check doesn't find anything.

Interesting is that after the restart i've propagated the permissions again and then they are gone. Until the next morning.. I wanted to be sure and run the propagate again, now the error's are back.

Anyone seen these? Google isn't very helpful.



Xsan 3: Invisible "__defragtmp" files are created after using snfsdefrag (Apple KB)

When defragmenting a file with snfsdefrag on systems running OS X Mountain Lion v10.8.4 and earlier, an invisible "__defragtmp" file may be created which cannot be deleted.
This issue may occur when the following are true:

The defragmented file's name contains precomposed Unicode characters, such as letters with diacritical marks (an accent, grave, or umlaut).
snfsdefrag is run by root.
snfsdefrag is run when the current working directory is on an Xsan volume, or snfsdefrag's recursive option (-r) is used.

Read more:

buchau's picture

XSan Permission Issue and ..

We currently moved from
Mac OSX 10.6.x MDCs using XSAN 2.2.x / Mac OSX Open Directory / XSAN 2.2.x Mac OS X 10.6.x Clients / Promise Storage ( all connected via Fiber Switch )
StorNext MDCs ( M440 Appliance ) version 4.7/ New Storage / Old Promise Storage was left intact and still being utilized / New MAC OS X 10.8.x XSAN Clients / Two new Windows 2008 Servers utilizing Stornext Clients All still connected via Fiber Switch.

All The Fiber connected Clients Mac OS X 10.8.x ( XSAN Client ) via Fiber & Two Windows 2008 R2 Server ( Stornext Client ) can see the old ( XSAN ) LUNs & the new ( StorNext ) LUNs and mount the volumes ( lets call this xsan1 and snfs1 ) I can see and access ALL the folders via the MAC OS X 10.8.x fiber clients but via Windows I see the volume but am not able to access "all" the contents. At first I saw the generic permission message indicating " You don't currently have permission to access this folder. Click continue to permanently get access to this folder"
At which point I can choose to continue, and take ownership of the folder. that works to a certain extent but I still get access denied while taking ownership of multiple folders and so on ..... I have been reading up on this issue and came across few things but figured I would come to the PROs and see what is the best way to approach this issue.
I also would like to utilize my Active Directory Domain to authenticate users to login to the MACs and also permission to the old Xsan volume and new snfs volume.
any help is greatly appreciated and I look forward to hearing from the PROs

eWhizz's picture

Expected speed? Promise Vtrack E-Class 32TB (16 x 2TB SAS)

What would the expected range of speed be from the following —

Apple Promise VTrack E-Class 32TB RAID Subsystem for MAC OS X w/ 16x 2TB SAS

We would expect to create two RAID6 LUNS and then stripe them together using Mac OS X Software RAID Striping and share the resulting volume using MetaSAN.

I know you guys are more specialising in Xsan rather than MetaSAN, but you are also the most likely group of people to know the answer to this one.

Thanks, in advance.

jetsenwang's picture

About 10.8.3 Xsan admin and 10.6.8 client

About 10.8.3 Xsan admin and 10.6.8 client

MetaData Controller : 10.8.3 Server Xsan3.0
Client:10.6.8 Xsan 2.2.2

How to connect?????

DLpres's picture

New SAN, can't add any clients (Failed to write conf. files)

This is a fresh XSAN, I started with a clean install on a wiped 10.8.5 ML Server (Xserve 2009). Have LUNs, volume, and already migrated some data to it. So far so good.

I tried for 2 hours to add (10.8.5 and 10.8.4) clients with no success. I enable XSAN in SysPrefs, XSAN Admin sees the clients easily, I authenticate, but after a while I get the message:
"Failed to write configuration files on computer"

The first 'client' was another server which I was going to promote to a secondary MDC, but never got this far. The other client was a normal Mac Pro.

I checked pings, DNS (dig), changeip -checkhostname, everything resolves just fine. OD is in place, separate private metadata network set manually with a separate subnet.

Are there any log files that'll show in more detail what's failing and where?

One thing I just thought about is that our entire facility DNS is set with A records for machines ("Solo") and CNAME for roles ("edit1"). The Add Computers window shows the CNAMEs for the machines, which looks just the way I expect it to, but is there something against having CNAMEs in an XSAN environment?

matt321's picture

10.8.5 Update and FinalCut X (10.0.9)

We are having issues since the 10.8.5 update with FinalCut X (10.0.9) randomly unmounting XSAN volumes.

Only rebooting the workstations fixes the issue.

Anyone having similar issues since updating?

DLpres's picture

Anyone got Unscale's HD Speed Test utility?


This little piece of software was touted here before as a great benchmark tool, since it generates data the same way an NLE does, giving a better simulation of video environment.

The problem is, Unscale has gone poof, their blog is gone, their website became Chinese, and it seems that there are zero copies of the software available elsewhere.

The latest version should be 1.2.2, does anyone have it?

Promise VTrak: Configuring for optimal performance (Apple KB)

Configure Promise VTrak RAIDs for best performance using the guidelines in this article.

Read more:

lucasnap's picture

High fsm CPU load on Xsan 3 Mac OS 10.8.4 MDC


We're running our 68TB Xsan volume on 10.8.4 for a view months now and a big difference between this version and the old 10.6.8 Xsan 2.2.2 volume is that the fsm CPU load is a lot higher than before.

We were used to a CPU load around 5 till 10% on our early 2009 Xserve but now we are seeing a CPU load around 100 till 150%.

It is a busy volume with around 25 clients doing all sorts of video stuff. And it is a clean installed volume: Clean install of Mac OS on the MDC's and a fresh Xsan File System.

It would be great to hear your experience.

Kind regards,



Subscribe to Xsanity RSS