Mavericks OD Replica problems on upgrade

xsanguy's picture

Upgrading ML Xsan MDCs to Mavericks - same issue on every system we build in the lab and several clients - OpenDirectory Replica does not survive. Attempts to re-create the OD replica fail with this message:

2013-12-23 07:58:15 +0000 NSMutableDictionary *_getRootDSE(const char *): rootDSE not found
2013-12-23 07:58:15 +0000 Error: Unable to determine the master's software version.

And yes I've tried the SSH fixes. They don't seem to do anything.

abstractrude's picture

How about destroying the replica. Upgrading the master then re-establishing a new replica?

-Trevor Carlson
THUMBWAR

OCPSTV's picture

I just upgraded both my Mac mini Xsan servers and one of my editors to 10.9.1 and I'm having a strange OD problem of my own. I'm using Profile Manager for Local Network users, and I can't log in as a LNU in 10.9. The user's password is rejected.

 

However; the plot thickens.  My Xsan servers "broadcast" the OD under the metadata network nameserver "xsan.metadata.domain.net" but my Profile Manager runs on the public enternet network "xsan.xsan.domain.net". When I bind the client to the broadcasted OD, I can't log in. If I mannually bind to the public LAN network, I can log. Once logged in, I eventually get Profile Manager connection errors that say the OD is not responding. This causes all kinds of havic while logged in as a LNU. I bassically have to log out and log in as the local admin user to dissconnect from the OD and rebind again.

 

The only thing I found relating to this is a possible bug with Cisco network switches and AnyConnect that drops VPN clent services in the same manner. Hardware which we do use for the public network.  Perhaps the two issues are cousins with the way Mavericks handles network connections.

 

My 10.8.5 workstations are having no problems at all, even with the servers on 10.9.1 perhaps it's just a Mavericks client issue. 

Film & Video Guru turned Mac & Xsan systems admin by necessity. I have much to learn.