config files in Library/Filesystems/Xsan/ are DELETED.HELP!!

fadi's picture

Crashing in Xsan Volume suddenly 3 day ago, until now cannot MOUNT the VOLUME .
all the files & folders in Library/Filesystems/Xsan/ are deleted

tried to verefied the volume from Disk Utility .. but every time the same error ( partition map check failed because no slices were found )

unfortunately have no backup, and i can't lose the DATA on volume it's very important .
ANY ONE EXPERT HELP PLEASE !!!!!!!

1- G-Technology - G-speed FC XL 12 TB
2- Using Raid 5 +1 + hot-spair
3- Q-Logic 1400 Fiber switch 10 Ports
4- Apple Fiber Channel Card
5- a (One) MDC MAC pro 2x2.26GHz QUAD-CORE - INTEL 0
b 6G MHz RAM DDR 3
c Mac OS x server LION 10.7
e Xsan V.2.3

singlemalt's picture

Wow. Sorry to hear that. I don't suppose this was actually a Lion server mdc was it?
According to your sig block this is a Lion server. The config files should be in
/Library/Preferences/Xsan with Lion.
Also Disk utility will do absolutely nothing with an xsan volume even if it was in perfect health.
Disk utility expects an HFS volume format. Xsan is a cluster file system.

fadi's picture

Thanks a lot " single malt " .. but now & after Millions of attempts Terminal and command line .. our status as follow :

  • The " SAN" volume is mounted now but giving us 10 TB free capacity .
  • some expert engineer told us that the volume is not damaged & the DATA still on it .
  • i'm trying now SCAN the "SAN" by ( Disk Drill Media Recovery ), and we can see the data recovered but it'll take 30 hours to finish scanning .

i can see the media files now on scanning window .

can any one explain why the "SAN" show up the status ( EMPTY ) but in the same time it contains DATA ??
and do you think that the recovery will success ???

singlemalt's picture

I'm a bit skeptical of data/disk recovery apps when xsan is involved. According to their web site...
... recovery on HFS and HFS+ (journaled/extended), FAT16 and FAT32, NTFS, EXT3, EXT4 and actually any other file system, or even on disks that were formatted or initialized...
but it doesn't mention ACFS ( Apple Cluster File System). But if it is seeing files then maybe it will work.

Out of curiosity, what happened when you ran cvfsck?