Labeling LUN: SANTransactionErrorDomain

kolekole's picture

Hello there Xsanity members!

Im fairly new to setting up Xsan systems and here in our company we are currently setting up one.

I will try to be short and concise:

We are unable to label one of the LUN's. The smallest one 3TB LUN which is designated for Metadata cannot be labeled and thus unusable in Xsan.

After trying to relabel that 3TB lun through XSAN admin i get UI message "Failed to label LUNs on computer MDC1's Mac mini."

Also system log is automatically printing out "Error labeling luns: The operation couldn’t be completed. (SANTransactionErrorDomain error 1.) (1)".

I have found one similar Xsanity thread where lucky fellow managed to solve issue by rebooting both MDC's which didnt helped us.

Other three LUN's are visible and usable.

Hopefully someone can shed some light on this issue.

Regards

JSamuel's picture

What does the cvlabel command show you?
$ sudo cvlabel -l

Are you sure the LUN hasn't been caught and formatted as HFS+ (etc) by a machine? Xsan won't label such a LUN, you would need to format it as free-space to 'release' it.

I assume as you're setting this up, there is nothing on it. The simplest might be just to re-create that LUN so your devices can pick it up again? (I assume your zoning/DNS etc are all configured)

Joel Samuel.
/thirtytwo - Apple Consultancy & Direction
Proud sponsor of Xsanity.com

All contributions are my own personal opinions - not those of any entity I represent.

kolekole's picture

Output of cvlabel:

/dev/rdisk3 [JMR VirtualDisk 0001] unknown Sectors: 5860415967. Sector Size: 512.
/dev/rdisk4 [JMR VirtualDisk 0001] acfs-EFI "PlayoutB92"Sectors: 23441719263. Sector size: 512. Maximum sectors: 23441719263.
/dev/rdisk5 [JMR VirtualDisk 0001] acfs-EFI "IngestB92"Sectors: 41023022559. Sector Size: 512. Maximum sectors: 41023022559.
/dev/rdisk6 [JMR VirtualDisk 0001] acfs-EFI "ProductionB92"Sectors: 82046063583. Sector Size: 512. Maximum sectors: 82046063583.

Device that buggers us is /dev/rdisk3 ofcourse.

we have recreated raid 1 on for that lun but same error persists.

We have started sudo cvlabel -r /dev/rdisk3 in hope that will solve some issues waiting on it to finish

Currently in setup there are only two MDC's so we werent paying any special attention to zoning and DNS but as we manage to get these two going we shall sort those out.

When you speak of DNS i presume you are talking about reverse lookup zone. Is there any advice you can give us on that subject?

Thank you for your reply!

Regards

kolekole's picture

We have tried recreating LUN several times and there were no changes. Same issue persists.

Is it viable to go with raid 5 for metadata lun?

Regards

abstractrude's picture

Your metadata performance will suck with RAID5.

-Trevor Carlson
THUMBWAR

xsanguy's picture

I have a few ideas, but they depend a lot on what you've already done, and your storage. It looks like JRM from the headers, but what model? Also the history of that LUN is something I'm very interested in. Finally, you could be having a 2.2/3TB problem.