New SAN, can't add any clients (Failed to write conf. files)

DLpres's picture

This is a fresh XSAN, I started with a clean install on a wiped 10.8.5 ML Server (Xserve 2009). Have LUNs, volume, and already migrated some data to it. So far so good.

I tried for 2 hours to add (10.8.5 and 10.8.4) clients with no success. I enable XSAN in SysPrefs, XSAN Admin sees the clients easily, I authenticate, but after a while I get the message:
"Failed to write configuration files on computer"

The first 'client' was another server which I was going to promote to a secondary MDC, but never got this far. The other client was a normal Mac Pro.

I checked pings, DNS (dig), changeip -checkhostname, everything resolves just fine. OD is in place, separate private metadata network set manually with a separate subnet.

Are there any log files that'll show in more detail what's failing and where?

One thing I just thought about is that our entire facility DNS is set with A records for machines ("Solo") and CNAME for roles ("edit1"). The Add Computers window shows the CNAMEs for the machines, which looks just the way I expect it to, but is there something against having CNAMEs in an XSAN environment?

DLpres's picture

Some more useful information:

MDC:
Sep 21 12:17:20 ppmdc1.ourcompany.com xsanmgrd[2021]: Got error -9806 for SSLHandshake remote address is 192.168.122.222:12737
Sep 21 12:17:20 ppmdc1.ourcompany.com xsanmgrd[2021]: Exception in SessionController threadListen: Socket: Connect failed

Client:
Sep 21 12:17:08 prserver.ourcompany.com xsanmgrd[1095]: xsan: [1095/A401F330] ERROR: -[XsanPlugin(History) testConfigFile:]: Trouble with stat of '/Library/Preferences/Xsan/config.plist'
Sep 21 12:17:08 prserver.ourcompany.com xsanmgrd[1095]: xsan: [1095/A401F330] ERROR: -[XsanPlugin(History) testConfigFile:]: Trouble with stat of '/Library/Preferences/Xsan/notifications3.plist'
Sep 21 12:17:13 prserver.ourcompany.com kdc[57]: TGS-REQ prserver.ourcompany.com$@prserver.ourcompany.COM from 127.0.0.1:63573 for host/prserver.ourcompany.com@prserver.ourcompany.COM [canonicalize]
Sep 21 12:17:13 prserver.ourcompany.com kdc[57]: TGS-REQ prserver.ourcompany.com$@prserver.ourcompany.COM from 127.0.0.1:62173 for ldap/prserver.ourcompany.com@prserver.ourcompany.COM [canonicalize]
Sep 21 12:17:49 prserver.ourcompany.com xsanmgrd[1095]: xsan: [1095/A40297E0] ERROR: -[XsanPlugin(WriteConfiguration) writeConfigurationWithRequest:]: unable to get address info for 'prserver.ourcompany.com': nodename nor servname provided, or not known

1. I tried to SSH myself from the MDC to prserver. It resolves right away to the proper public IP of prserver. I get the warning that the host's authenticity can't be established, and after continuing it takes a long time to get the password prompt, but otherwise it works.

2. Confused what to make of "Trouble with stat of '/Library/Preferences/Xsan/config.plist'" since there is nothing in the Xsan folder besides the uuid.

3. On the MDC, I ran file, plutil, and ls -leO against config.plist and all looks good.

I can try to manually populate the client's XSan folder with config.plist etc., but there's probably something more fundamental going on that needs to be resolved.

nrausch's picture

On the 2 clients, do you already have any directory services setup?

If so, try removing them and rebooting.

Log into client machines as a local admin account, and try to add clients again. Let XSAN admin MDC setup directory services for you automatically.

Hope that helps.

abstractrude's picture

I would take a look at your metadata network. Adding a client is done over public, but creating the config and finishing up is over the metadata.

One more note though, I have seen this before where a client will not add no matter what. In that case, I reinstalled the os. I never got to the reason for the issue as I didn't have time to investigate. The only thing I know, is the system (client) seemed to believe it was member of another SAN. So in these scenarios It usually means the Xsan was built and messed around with previously.

-Trevor Carlson
THUMBWAR

tonyswu's picture

In Mountain Lion, the folder /Library/Preferences/Xsan does NOT create itself if you remove it. I know a lot of us liked to remove the whole folder back in the 10.6 days (so to get rid of the hidden files as well), but if you do that in Mountain Lion you must recreate that folder manually, otherwise it will not allow you to write the configuration files.

I ran into this first in 10.7, and later in 10.8.1, not sure if it's still the case with the recent updates.